I'm a Premium User looking for support, 3.8 is simply does not work

Fatal Application Exit error upon launching Game Show

An Unhandled exception has occurred.

Uninstalled , reinstalled , same error . Link to older version 3.7 please until 3.8 has bugs worked out .

9replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Also TeleStream has no support Page for Game show or is well hidden

  • Curious, with 3.8 did you try to create a new template or project and see if GameShow opens?  I have had this similar issue when upgrading to new version it will crash opening an existing project.  Also maybe try resetting preferences in the support assistance.  


    I know I know should not have to do that.  

  • Where do you reset preference in the support assistance ? the only link i have to support page in through email . It tells me that i need to select my desktop application and then select premium support . When clicking the link , it takes me to a cover all page of all of their products none of which are Game Show .

  • Support Assistance is a program located with GameShow.  Should be in your windows start

  • I Stream Daily. I searched and found a Link to 3.7


    Having a working Version to fall back on is a must Seeing how hard it is to get a hold of support.

    Hopefully in future releases (Opening Existing Projects Bug) will be fixed.

    On this page


    which is the correct choice ?

    I Reset the Preferences and re downloaded/Installed 3.8 . have to restart to see if it works.

  • Restarted and 3.8 is now working .

      Would you recommend Starting from scratch or import an existing project ?

  • Thank You Mr. GameSpeaker for all of your help it is much appreciated.

  • while the App does launch , when trying to stream we get a Blank screen and loud buzzing sound from left channel. Just tried Xsplit Works Fine , will buy . Unless we can get game show working.

  • I had this issue with the 3.8beta release. I could point out the audio device (microphone) as the source for that error. I use different shots with mic as device and without. I had to save my doc with a shot selected as live other than mic activated. Then i had to change the audio device everytime to my mic to get it to work. But with the 3.8 public issue is gone for me

  • 2 yrs agoLast active
  • 9Replies
  • 758Views
  • 3 Following