Alpha Release. Osx open sourced piped Driver.

So because I talked to the game show people and they said it was ok to release here, the game show piped driver for HD HD 60 and Pro lines, this is a alpha driver, it may work on your system it may not.

 

Things to note, you will have to adjust video audio latency,  650 -1500 respectively. 

 

From your source, run ./elgato-hd -r <resolution>, whereas <resolution> can be 1080p or 720p for a HDMI source, c1080p, c1080i, c720p or c576p for a component source or 576i for a composite PAL source. Hd 60 and HD 60 PRO wont be able to use C sources as they do not offer Component connections.

 

Any questions feel free to ask. Download Attached.

129replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • From your source.........................

     

    English please..........I'm sorry.........Thank you, by the way. Does this work on Yosemite?

    Reply Like
  • Stickied!

    Reply Like
  • Source being the directory you put it in. 

    Reply Like
  • Required driver

    libusb --osx may ship with this if not you will have to install brew to get lib usb.

     

    Directions

    Unzip file

    From terminal navigate to the folder.

    Make sure the firmware folder is also in the same directory.

     ./elgato-hd -r <resolution>, whereas <resolution>  first resolution is input second is output.  so say 1080p 1080p or 1080p 720p output.

    Use the file name I may have forgot I renamed the file to keep local version testing from production version.

    that command has to be done in terminal, once you are done you must hit CMD c to end

    The piped output file will be the file you need to add to gameshow as a video

    Reply Like
  • ....................................................................................................

    .....................I still don't get it.

     

    Also, download link for "libusb"? Does it work with the LGP Lite as well?

    Reply Like
  • You would need to install brew then brew install libusb, it may work without it , It should be compiled directly into it but just in case if it does not work and says requires . 

    Reply Like
  • I do not know how to make it more simple.

    Extract archive , from your osx terminal navigate to that folder, run it from terminal.

    When you see the file it makes open game show open your project in game show add it as a video navigate to where it is, put that in there setup stream as normal sync your audio video like normal.  

    Reply Like
  • ok, tried to install and failed

    installed brew libusb (ver 1.0.20) and then ran command via terminal
    got this:
    Unable to find device.
    Terminating.

    OSX 10.10.3
    Elgato HD60

    Reply Like
  • Let me check, I think I may have forgot to include the firmware files in the folder. 

    Reply Like
  • No they are there, humm can you do a a copy paste of how you are running it to just make sure it's actually being put in correctly. 

    Reply Like
  • I tried doing it on my own............

    Didn't work. I tried following the instructions, but I literally have no idea what I'm doing.

    Reply Like
  • I never used Terminal before. So there's that.

    Reply Like
  • I have same results as Gr Tr 

    Reply Like
  • Ok, I will upload the original firmware I built the driver on, I think the new one they sent me may have a bug in it , sorry about that, with not anyone testing  I did not know if it was just a local issue.

    Reply Like
  • I brewed libusb, tried the command: "./elgato-hd60 -r 1080p" , got the same output as other people : Unable to find device terminating.

    Reply Like
  • Hmmm, I wonder why it worked for me when I tried it.

    Reply Like
  • Do you use a HD60 plugged on a Mac USB port ?

    Reply Like
  • Should have read the original post better. Doesnt work on HD 60 :'( 

    Any hope for me?

    Reply Like
  • I downloaded libusb. I have no idea how to homebrew it. And again, I've never used terminal.

    Reply Like
  • Rodolphe Nenert 

    From my understanding it should work for all three original devices,HS HD60 and HD60Pro. The HD60S probably wouldn't work at all as I do not believe Jamie posted this with the firmware for that device due to how new it is vs when he was working on this.

    Reply Like
  • Bryce Stejskal 

    well then it doesnt work woth my HD60

    Thanks a lot to OP for his hard work, I hope a fix will come soon and fix our issue :)

    Reply Like
  • The only thing I can think of is some of the Hd 60s have different Device Id's then some of the others.  Before posting this Bryce tested the driver.  Can those of you with non working version send me the PCI device ID of your device, if it does not match I will add it to the list. 

    Reply Like
  • Which is where?

    Reply Like
  • ok, I installed Homebrew and Libusb. I researched how to navigate through the terminal and I still can't get it to work. I put the folder on my desktop where I navigated in terminal. I ran the code a few times trying out different things....

    "Gabriels-iMac:~ gabrielperez$ cd desktop

    Gabriels-iMac:desktop gabrielperez$ cd elgato-hd60

    Gabriels-iMac:elgato-hd60 gabrielperez$ run ./elgato-hd60 -r 1080p 1080p

    -bash: run: command not found

    Gabriels-iMac:elgato-hd60 gabrielperez$ ./elgato-hd60 -r 1080p 1080p

    dyld: Library not loaded: /usr/local/opt/libusb/lib/libusb-1.0.0.dylib

      Referenced from: /Users/gabrielperez/Desktop/Elgato-Hd60/./elgato-hd60

      Reason: image not found

    Trace/BPT trap: 5

    Gabriels-iMac:elgato-hd60 gabrielperez$"

     

    Not sure what I am doing wrong?

    Reply Like
  • BTW, thanks for the hard work giving your time into this! I appreciate the effort getting this out.

    Reply Like
Like6 Follow
  • 6 Likes
  • 1 yr agoLast active
  • 129Replies
  • 4852Views
  • 15 Following