Alpha Release. Osx open sourced piped Driver.

So because I talked to the game show people and they said it was ok to release here, the game show piped driver for HD HD 60 and Pro lines, this is a alpha driver, it may work on your system it may not.

 

Things to note, you will have to adjust video audio latency,  650 -1500 respectively. 

 

From your source, run ./elgato-hd -r <resolution>, whereas <resolution> can be 1080p or 720p for a HDMI source, c1080p, c1080i, c720p or c576p for a component source or 576i for a composite PAL source. Hd 60 and HD 60 PRO wont be able to use C sources as they do not offer Component connections.

 

Any questions feel free to ask. Download Attached.

129replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Did you run brew linkapps to link the the bash command so you have access locally.  If not that is why you are getting the Lib USB error.

    Reply Like
  • I got the brew linkapps to work.

    "Gabriels-iMac:~ gabrielperez$ brew linkapps

    Gabriels-iMac:~ gabrielperez$ cd desktop

    Gabriels-iMac:desktop gabrielperez$ cd elgato-hd60

    Gabriels-iMac:elgato-hd60 gabrielperez$ ./elgato-hd60 -r 1080p 1080p

    /tmp/elgato_gchd.ts has been created. Waiting for user to open it."

     

    I am stuck here... I opened gameshow. I also pressed 'cmd + c" but nothing happens.

    Reply Like
  • Did you add elgato_gchd.ts as a media file in your document?

    Reply Like
  • In terminal, it says it created elgato_gchd.ts in my /tmp directory but it's not there at all... weird 

    Reply Like
  • Maybe you need to run that last command as sudo in order to grant permissions for it to make the file, and it just didn't notify it was unable to create?

    Reply Like
  • I'm running the command as sudo and it still doesn't show up under /tmp ... 

    "Gabriels-iMac:elgato-hd60 gabrielperez$ sudo ./elgato-hd60 -r 1080p 1080p

    Password:

    /tmp/elgato_gchd.ts has been created. Waiting for user to open it."

    any other possible solution? 

    Reply Like
  • This still doesn't make any sense to me.

    Reply Like
  • Humm I will have to look into that, one thing you can do just in case, fix perms on your mac hdd just in case, but I will go over the code just in case I goofed on the perms to make the file. 

    Reply Like
  • Bryce why it worked for us and not them is if your mac is in Developer mode, it has permission to write a temp directory /tmp in the root directory of the system.  I will fix that in the driver, :) , it should have wrote it to the same folder as the driver for ease of use, it was my mistake, I uploaded the wrong version .  Since  I need to make this simpler for people to use. 

    Reply Like
  • To see if it did make the folder open your mac hdd while it is open and look for /tmp/name of file then open that in game show.  

    Reply Like
  • so I re-downloaded the file and did the procedure again. I get this:

    "Gabriels-iMac:elgato-hd60 gabrielperez$ sudo ./elgato-hd60 -r 1080p 1080p

    Password:

    Could not activate configuration.

    Could not claim interface.

    Terminating."

    I did tried it regularly without sudo too.

    Reply Like
  • That is a libusb error that it cannot claim the device because it thinks the device is already in use.   You can try to unplug the device and plug it back in, hope that clears it out, I need to implement better error handling. 

    Reply Like
  • ok I unplugged the capture card from my computer and plugged it back in. Wrote the code in terminal and elgato_gchd.ts has been created but it still doesn't show in my /tmp directory.

    Reply Like
  • i actually tried again and it worked this time... except my screen is green lol

    "Gabriels-iMac:elgato-hd60 gabrielperez$ ./elgato-hd60 -r 1080p 1080p

    /tmp/elgato_gchd.ts has been created. Waiting for user to open it.

    Running. Initializing device.

    Streaming data from device now."

    only thing is that the file elgato_gchd.ts is still not in my /tmp

    Reply Like
  • Yea the screen would be green because it needs that file...  But humm, while it is running try to search for the .ts file.  I only say that because  it should be /tmp/file name.  

    Reply Like
  • Ive tried it a few more times and have searched my computer for that file and nothing. I even looked up how to unlock and see hidden files through terminal and the file isn't in /tmp nor anywhere in my mac...

    I am running El Capitan if that even matters. I find this so weird as it states that the file has been created...

    Reply Like
  • Jamie Freeman 

    Is it the firmware from the Windows version? Or something else?

    Also, as I said I have never used Terminal before, so I really need help........

    Reply Like
  • El capitan would not matter as that is the system I built the driver on .  Yea that is what is puzzling me to why it is saying the file is created when it is not, I put in an error code if it cannot actually make the file.

     

     Donovan, 

                 The firmware is from the device they are os independent, the firmware does not care if it is windows linux or osx.

    Reply Like
  • Any chance of a fix for people who have the "unable to find device" problem? :)

    Reply Like
  • There has to be a reason why it wouldn't appear in my /tmp folder. I did fix my perms in my mac hdd and that didn't help. Any other solution you can think of? 

    Is anyone else having issues with the file "elgato_gchd.ts" not showing up in your/tmp folder?

    Reply Like
  • no, I'm stuck on the unable to find device error.

    Reply Like
  • Jamie Freeman 

    How do I navigate to the folder and run it? I never use Terminal. I need serious help.

    And what the heck is "bash"?

    Reply Like
  • Donovan Lewis To make it easier for you, put the file that was downloaded in this thread onto your desktop. 

    Open Terminal.

    type in "cd Desktop"

    After, type in "cd elgato-hd60"

    Then you type in "./elgato-hd60 -r 1080p 1080p"

    (you can change the 1080p 1080p to whatever you want. The first one is the native res and the 2nd is what you want it to output for the stream. Mine would be 1080p 720p because I want it to output 720p instead of 1080p)

     

    It'll create a file into you /tmp folder which you need to open with in Gameshow using the media file option instead of video capture.

    To navigate to your /tmp file, just open your 'finder" and hold down the cmd+shift+g and type "/tmp". It'll direct you to the directory where the file is.

    Hope this helps.

     

    (ohh and you do need home-brew for this...

    Paste this in your terminal and it'll install for you:

    /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

    Then you type "brew install libusb" and then you'll be all set to continue on)

    Reply Like
  • Thank you so much. I'm gonna honest, though. After trying to test so many things, I'm not even sure if I can even use Gameshow. I mean, I never had a problem with it until now. Thinking I need a stronger computer now......

    But I'll give it a try anyways and see what happens. Again, thank you for the help. And thank you Jamie Freeman for making the driver.
    Reply Like
  • Do I press enter after I type all of that? And does Gameshow need to be open?

    Do I download the libusb homebrew from here?

    http://libusb.info/

    Reply Like
Like6 Follow
  • 6 Likes
  • 1 yr agoLast active
  • 129Replies
  • 4859Views
  • 15 Following