Getting Echo/Reverb off of Discord - Don't Know Why

I have a situation that is really puzzling. I am trying to stream pen an paper RPGs on Roll20, which is a virtual tabletop. We are not using Roll20's native audio. Instead, we are using Discord, primarily because Roll20's audio is unstable and unreliable at this stage.

My personal audio (which is coming from a Blue Yeti mike) is working perfectly, but all of the audio coming over Discord is reverbing (it sounds like only one "echo"). I have not been using headphones, but the Yeti is in cardiod mode, and this doesn't sound like a feedback loop to me (it doesn't keep looping on and on - it just sounds like the players are in an empty hall).

I should also note that the audio sounds fine when it is coming out of my speakers live. I only become aware of the issue when I play back the stream once its finished.

I have tried all sorts of things to troubleshoot this, and its driving me nuts. I have had people join me on Discord and Roll20 and tried recording it - audio issue does NOT duplicate on the recording. I've tried it with my mike muted and not muted, etc. etc.

I am using System Audio Capture. I could, alternatively, use the "What You Hear" coming off my Soundblaster external card, but I am pretty sure I have had the same result with that one as well.

I can't for the life of me understand why I get no reverb with native system audio, or even on my recordings, but then it happens when I stream.

Could it be the additional stress on my system that comes from multiple people being logged into Roll20 and Discord when I stream? That seems like an odd result.

Here is what it sounds like:

https://www.youtube.com/watch?v=sTYrfnedcV4&t=467s

Edit: I am using 3.9, so I should not be affected by the surround sound issue...

5replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Just bumping this request for help - anyone have any idea why I would get the echo/distortion off Discord when I'm streaming?

  • Are you previewing your audio on the website while you are doing your stream?
    Doubling audio would not be related to performance, usually if your system is under too much load the audio will appear choppy.

    Also double check your audio mixer and make sure you don't have any FX enabled.

  • I do sometimes have the Twitch stream running in a browser tab. But it is muted, and when I accidentally forget to have it muted, I can hear it myself and correct it quickly. I also don't think that is it because the timing between the stream and the live audio is several seconds, and this "echo" is almost immediate.

    I'll double check the mixer for an FX. That would be embarrasing, but I don't think that's it.

  • I have the exact same problem. Did you ever get this resolved?

  • Matthew Ames This was original with version 3.9. The last release of Gameshow was 4.5.1 so you may want to test with that.

Follow
  • 4 mths agoLast active
  • 5Replies
  • 10744Views
  • 5 Following